
User manual

Please read this manual carefully before the usage of
SMDVISIO

and keep it for further reference.

SMDVISIOSMDVISIO
Robotic MicroscopeRobotic Microscope
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Notice
HEXEL electronics s.r.l. reserves the right to change the specifications of the 
hardware and software described in this manual at any time and without prior 
notifications.
The PC program runs only on Windows10 and upper. 
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1) General Description 

The SMDVISIO is a robotic microscope for inspection of the correct assembly of
SMD or PTH components on printed circuit boards.

The machine allows the simplification of the operations related to the 
inspection of circuit boards by simultaneously providing a magnified image of 
each mounted component, its data (code, value, mounting position & 
orientation) and a reference picture of its correct installation on the board.

By comparing these information with the actual mounted component an 
operator can easily verify the correctness of the assembly. 

SMDVISIO is an excellent support for quality certification as the control is 
carried out directly by a qualified operator and thus avoiding the uncertainties 
associated with automatic control subject to imponderable variables.

2) Work EnvironmentWork Environment   
 
2.1)The SMDVISIO is meant for indoor usage where a proper power 
       source is provided. The SMDVISIO should be stored in a clean and 
       dry place if not in use.

2.2) Do not expose the SMDVISIO to rain or other humidity.

2.3) Place the SMDVISIO on a solid, hard, dry, stable surface. Leave
       proper clearance around the SMDVISIO (min. 10 cm). Do not place
       the SMDVISIO on a damaged or fragile surface.

3)   Features 

Net weight: 18 kg approx.
Gross weight: 20 kg including the shipping box
Dimensions: 600×500×200 mm
Maximum dimensions of the PCB in inspection: 400 mm x 270mm
Maximum PCB size that can be inspected: 380 mm x 250mm
Position precision: 0,2mm
Overall dimensions: 670×580×280 mm
Power input: 12VDC, 24W (wall wart adaptor supplied separately)
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4) Declaration of compliance  -  CE  

Producer: HEXEL S.R.L. - TRISSINO (VI) ITALY
Product Description: semiautomatic system for optical 

       inspection of electronic boards  
Power supply: 12VDC, 24W
Type: SMDVISIO

This SMDVISIO complies with the following directives and standards.

Directives:
2014/35/EU   Low Voltage Directive (LVD) 
2004/108/EC EMC Directive 
2011/65/EU   EU RoHS Directive 

Standards:
IEC/EN 61010-1:2010 

Safety requirements for electrical equipment for measurement, control, and laboratory use 
IEC/EN 61326-1:2013

Electrical equipment for measurement, control and laboratory use. EMC requirements. 
General requirements

5) Identification Plate

MODEL:  SMDVISIO 
Input Power:  12V / 2A
Producer: HEXEL s.r.l. - ITALY 
S/N: 00001/2018 
Made in ITALY

 
This symbol indicates you should not throw away 
the used SMDVISIO with household waste, 
and should be disposed to authorized entities,   
following the directions of the local authority. 
Alternatively it can be returned manufacturer.
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6) Safety precautions

Please read the following safety precautions before using SMDVISIO.

6.1) The manufacturer shall not be liable for any equipment damage or
       personal injury caused by incorrect installation or usage, other than
       that covered in this manual.

6.2) The SMDVISIO should only be used by trained personnel.

6.3) Only install on a horizontal stable surface, never on a slanted surface.

6.4) Do not modify any accessories and never use broken parts.

6.5) Before operating the SMDVISIO, always make sure that the power
       cable is not worn out or damaged.

6.6) DO NOT attempt to modify or repair the SMDVISIO by yourself. In
       case of damage, please contact us at info@hexel.it.

6.7) This SMDVISIO is not a toy. Keep it away from children or pets.

6.8) Maximal ambient temperature: +40°C (104°F).

6.9) Minimal ambient temperature: +15°C (41°F).

6.10) The PCB pins are small. Keep them out of reach of children.

6.11) The motors have magnets. Do not put items that are sensitive to
         magnetic fields around the SMDVISIO (credit cards, hard disks, 
  compasses, etc.)

NOTE: If you have a pacemaker, consult your doctor before using the 
SMDVISIO.
Ww
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7) Parts of the SMDVISIO

Y Axis Right side 
1. Adjust camera luminosity

   It adjusts the light intensity of the LED light .

Back Panel

1. USB connector Type B (camera port)
    It connects the SMDVISIO camera to the PC.

2. DC supply connector
   Use the recommended 12VDC 2A power supply, delivered with the
   SMDVISIO. Connector type: 5.5mm/2.1mm

3. USB connector Type A (service port)
    It connects the SMDVISIO to the PC for communication functions.
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8) Use of the PC software

System Requirements

Operating system: WINDOWS 10

Document reader: reader for .pdf file

Processor: 1 GHz or faster or SoC
RAM: 1 GB (32-bit) or 2 GB (64-bit)

Recommended Hard Disk Type: SSD minimum 120GB 
Free hard disk space: 16 GB (32-bit) or 20 GB (64-bit)
Graphics card: high speed card, 16 million colors, min. 4 GB DDR3

Display: 1024×768 minimum 

Com Port: at least two USB A ports available

Internet connection required  

9) Installing the software SMDVISIO 1.0

9.1) Initial operations.

       Insert the disk/pen memory provided with the machine, then open the 
       folder <publish>, finally double click on SETUP.
       Wait until the installation finishes.
       Connect the two USB cables from SMDVISIO to the PC.
       Launch the SMDVISIO program. The software will automatically detects    
       the links with the machine.

9.2) Service port.
      If a "Port not found" message appears then check for the correct  
      connection of the USB cable. 

      If the cable seems to be ok check the driver installation and remove the   
      USB connector of the SERVICE PORT, then try to reinstall the driver.

      To reach the Device Manager in Windows go to the Start menu and into the
      search box type "device manager", then hit enter.

      Into the installation disk/pen memory go to the folder   
     <CP210x_VCP_Windows> and start the driver's installation program,     
      when required connect the SERVICE PORT USB cable.
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9.2)  Camera port.
       If the machine is correctly detected go to Setup > Preferencies > Camera
       selection and select <USB2.0 UVC PC Camera> (machine's microscope 
       camera). 
       If you cannot find <USB2.0 UVC PC Camera> in the list then go to the 
       Windows Device Manager to see if the driver <USB2.0 UVC PC Camera> 
       has been installed properly (no exclamation point marker should appear).

       To reach the Device Manager in Windows go to the Start menu and into    
       the search box type "device manager", then hit enter.

       If the driver was not installed properly then try to reinstall it: first remove 
       the driver (if it was improperly installed) and remove the USB connector  
       of the microscope coming from SMDVISIO machine, into the 
       installation disk/pen memory go to the folder <CAMERA\Driver> 
       and start the driver's installation program, when required connect the 
       microscope's USB cable.
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10) Running the software SMDVISIO 1.0

10.1) Connect the power supply to powerline .

10.2) Connect the USB connector Type A (service port).
           Verify the correct drive installation.

10.3) Connect the camera via USB connector Type B (camera port).
         Verify the correct drive installation.

10.4) Start the software by double clicking on SMDVISIO icon 
         (smdvisio.exe).

It Will appear:
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11) Interface Description
11.1) Upper Bar Choice-File
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Open : open and import cad files
Save as : save the file as a data file

(extension .rpt)
Only the file including the fiducial 
and its location is saved   

Export as : export the file in CSV format
usable for traceability
for industry 4.0

Open project : open project files
(extension .vspj). Data, photos 
and fiducials are uploaded

 Save project as: save project files
(extension .vspj). Data, photos 
and fiducials are saved.
The project requires the name of 
the operator and the lot number.

Save FAI as :save the file as F.A.I. for the 
golden card (extension .rpt)
Save the file as a golden card to 
compare and it is loaded with
the button Load FAI button   

Compare Files : compare the old file with 
the new file and generate a 
table with the differences:

REMOVED COMPONENTS -> 
ROW COLORE BROWN LIGHT
ADDED COMPONENTS -> 
ROW COLOR GREEN LIGHT
MODIFIED COMPONENTS-> 
ROW COLOR YELLOW 
Need the reference fiducial  

Export Wrong Components:  export the 
components list checked in
WRONG column
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11.2) File -> Open: opening file cad ( extension .mnt or .txt or .vis ) 
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Open file – Loading File Parameters

File type :

File type to be imported

Invert X Axis :

Invert the axis X coordinate

Invert Y Axis :

Invert the axis Y coordinate

Value Separators : 

The files provided by the CAD program can
have up to three types of separators:

space or tab or other( i.e. ,   ;    :  ) .

File Headers : 

The files provided by the CAD program can
have up to 6 fields. You can select the 
order of the headings by acting on the 
selection N X Y R V P, to skip a field use J.

Measurement Unit :

The unit of measurement of the file can be
in mm or mils.

Multiple Electronic Boards : 

It is also possible to check multiple circuits
by setting the selection to Yes and 
indicating in "Number of boards" the 
number of circuits in X and the number of 
circuits circuits in Y.

Create FAI from Image/PDF : 

It is possible to create the FAI file from a 
topography in image / PDF format.

It is necessary to give the dimensions of 
the card in mm to correctly scale the 
image / PDF file.
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11.3)Setup ->  Preferencies  
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Select Marker: select for Marker 
dimension 

Select Camera: select for 
Camera

Select Com: select com port

Insert Multiplier X : 
ratio of x axis

Insert Multiplier Y: 
ratio of y axis

Max jog value X: maximum X 
quote value

Max jog value Y: maximum Y 
quote value

Jog movement value: minimum 
step(mm)

Offset Zero X : X offset zero 
position

Offset Zero Y : Y offset zero 
position 

Delay Autoshot : delay between 
photos during 
autoshot.

Zoom : camera zoom.

Import : load The setup 
values previously
saved.

Export : export current 
setup values.

Restore Default : restores 
factory values.

Save :  save current selections.
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11.4) Tools ->  Gymn
Mechanical test, put the start quote (i.e. 0-0), end quote 
(i.e. 100-100) then click on Gymn icon to start, another click to 

                 stop.  

Tools ->  Clear error
If there is an alarm           (   Click on Clear error to clear the card 
error.

Tools -> Duplicate Component 
Duplicate the current line
(Right mouse button -> Duplicate or CTRL + C).

Tools -> Erase Component 
Delete the current line
(Right mouse button -> Erase or DEL). 

Tools -> Assign Current Position
Update the quota of the component of the current row to the current 
dimension to view details of the component otherwise out of sight
(Right mouse button -> Assign Current Position). 

11.5) Info ->  
    Board info: information about the control card

            Firmware info: information about firmware
    Website:smdvisio.it
    Manual: link to guide on line 
    About Us: HEXEL srl information
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12) Button description 

Set Fiducial Position: 

Zero Machine: 

Go To Fiducial: 

Go To Components: 

Live View: 

Shots:

Jog :

Select as Fiducial: 

Move: 

It moves the camera to zero machine.

It moves the camera by arrows.

It moves the camera by arrows.

Arrows for camera movement. It's possible to use
the keyboard arrow in same way.
To move with step of 0.1mm press arrow.
To move with step of 2mm press shift and arrow.
To move with step of 6mm press Ctrl and arrow.
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It confirms the fiducial on pcb centered by camera.

It moves the camera to fiducial on pcb.

It confirms the NAME choice for a component in data table.

It views components by Live camera.

It views components by picture updated before.

It confirms the choice for fiducial reference in data table.
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Next Board:

Prev. Board:

Zoom+ :

Zoom- :

AUTO SHOT area

Start (Pause):

Stop:

Load Report:

Screen Shot:

It moves to the previus board (if there are panelized boards).

It loads sample imagine file .rpt.

It stops automatic shots.
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It moves to the next board (if there are panelized boards).

Zoom + increase the camera zoom.

It alternatively starts/pauses automatic shots.

Immediate photo of the component being inspected. The photos 
are saved in the SMDVISIO_Pictures folder on the desktop.

Zoom - decrease the camera zoom.

                                      user manual



13) Icon description

Busy:

Alarm:

Data Table: 

Picture: 

Report Picture: 

Components Data:
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Alarm from hardware (see name of alarm in the lower bar ) 

Data table 

Busy at the moment, don't use the program

Display the image of the component being inspected in
two ways:

immediate  LIVE VIEW            from camera

Photo - SHOTS             from the photos saved in the 
project 

Image of the component imported from the gallery 
of reference photos with the button 

LOAD REPORT  (  file.rpt ) 

Data value of the component under inspection
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14) Bottom Bar Description
Status bar : 

When the program is running you will see:
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Working Time :  time spent during photo acquisition session  
Project no: project number
Autoupdate board No. :  number of board for this work session  
Operator : operator name
Batch :  batch number
File :  name of the loaded project file
COM : number of control port communication
Current X,Y : actual position fos axis X and Y
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15) Use of the software - file processing

15.1)CAD file import  
File ->  Open ->   the menu opens  Loading File Parameters 

File Type : file cad type options
All files  for generic file cad
.rpt   SMDVISIO generated file cad with the  
        golden card. This file allows you to import the 

changes made to the original CAD file during the 
inspection of the golden card and to replicate 
them in the multiple circuit.   

Invert Axis : options for the Cartesian origin of the cad file:
if the origin is at the bottom left, do not flag anything
if the origin is in the upper right hand flagging Invert X Axis 
and Invert Y Axis
if the origin is in the lower right hand flag only Invert X Axis
if the origin is at the top left, flag only Invert Y Axis

Value Separators  : options for file cad separators
File Headers : options for file cad header

example of cad file line 

R49 93.98 59.05 270 22K FEEDER19 R0805
R49 component name    ->  N

 93.98   X quote value  ->   X
59.05   Y quote value ->   Y
270   component rotation  -> R
22K  component value  ->  V
FEEDER19  not used column -> J  (jump)
R0805 component package -> P
The File Headers will be :  N,X,Y,R,V,J,P
Use J to jump the unused column     

Measurement Unit : option for mm o mils unit measurement

Multiple Electronics Boards : Multiple Electronics Boards option 
Choose no for single pcb or golden card. 
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Multiple Electronics Boards :   Multiple Electronics Boards option
Choose Yes if the circuit is multiple. The multiple circuit must 
be in consecutive sequence, the circuit must be rotated. Set 
the number of circuits present in X and Y considering the 
square as a table, if there are circuits with different rotations 
select the rotation card by card with the right mouse button 
in the table
Boards' Rotation.

Once the configuration has been completed, confirm with the OK button at 
the bottom. If the configuration is correct, the program populates the data 
table with the values of the cad file and the machine positions itself on zero.

The program asks you to choose the line with the  fid.refѲ
(can also be a component) and confirm with the button 

           Select As Fiducial

then it asks to position itself in JOG            on the fiducial of the card in the lower 
left corner (Ѳ fid.ref. PCB n.0),

confirm with the Set Fiducial Position button

and then top right (Ѳ fid.ref. PCB n.3) and confirm again with   
 Set Fiducial Position

All the card fiducials are presented and require the confirmation of the correct 
position for each fiducial. If the multiple circuit has not been selected, only the 
acquisition of the first fid.ref will be performed. (Ѳ fid.ref. PCB n.0).

     PCB 2         PCB 3

  (rotaz. 0°)        (rotaz. 180°)

     PCB 0         PCB 1

  (rotaz. 90°)      (rotaz. 270°)
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Create FAI from Image/PDF 
To inspect the first card, not having available photo files can be used
topography in image / PDF format.
Check the box

Create FAI from Image / PDF
Click Load File (pdf or bmp, jpg, jpeg, png)
select the file, enter the dimensions
printed circuit board in mm and press OK, select the file cad of the 
card and the following screen is displayed:

Proceed by clicking on the Set Fiducial Position e button
place the mouse on the reference fiducial, give Enter and comes
highlighted the fiducial with a red square, repeat the operation
for the buttons Set Lower Left Corner (blue square) and Set Upper 
Right Corner (green square). Proceed with the Create FAI button which
will present the file save menu.
If everything is correct, the image of the topology will be presented
on the control panel on the right than in the center.
In normal use, loading as FAI the one generated with the
Create FAI from Image / PDF you will have the following screen
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15.2) Saving the golden card report file
File -> Save as: save the file as a report file (.rpt) including the fiducial, its 
position and all the changes made to the original cad file.

15.3) Saving the report file in CSV format
File -> Export as: export the data file in CSV format usable for traceability
of the lots usable in the "Industry 4.0"

15.4) Opening of project files
File -> Open project: open project files (extension .vspj). The data, photos and
fiducials of a project (or lot) previously processed are loaded.
This function allows you to set up the machine for processing
subsequent projects (or lots) without having to repeat the import operation 
of the cad files

15.5) Saving the project file (or lot)
File -> Save project: save project files (extension .vspj). Data, photos, fiducials 
and any changes made to the project (or lot) are saved.
To process the project (or lot) it is necessary to import the CAD file the first 
time original, execute the fiducial learning sequence, verify the correct
positioning and launching the AUTOSHOT 
sequence for the acquisition of all the 
photos. Once the sequence of photos is finished it is possible to save
The project that requires the operator's name (Operator)
and the batch number (Batch). At the end press the 
button OK to execute the save.

ATTENTION : when saving (green bar at the bottom) do 
not perform other operations that could compromise 
the saving of the file itself!

15.6) Saving the FAI file (golden card or First Inspection Article)
File -> Save FAI as: save the file as FAI for the golden card (extension .rpt)
Save the FAI file (golden card) to be used as a comparison and loaded
with the button Load FAI button.

To process the FAI file (golden card) it is necessary the first time to 
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import the original CAD file, execute the learning sequence of the 
fiducial (single card), verify its correct positioning and launch the 

AUTOSHOT sequence
 for capturing all the photos. Once the photo sequence has been completed, 

perform a careful verification of the correspondence of the components and
save the FAI (golden card). To use the FAI file upload with the button

Load FAI button.

ATTENTION : when saving (green bar at the bottom) do not perform other 
operations that could compromise the saving of the file itself!

15.7) Compare the old file with the new file 
File -> Compare Files : Compare the old file with the new file and 

generate a table with the differences:
REMOVED COMPONENTS -> ROW COLORE BROWN LIGHT
ADDED COMPONENTS -> ROW COLOR GREEN LIGHT
MODIFIED COMPONENTS-> ROW COLOR YELLOW 
Need the reference fiducial  
This function allows the comparison between two files (old and 
new) relating to the same project that may have undergone minor 
changes and that requires to be generated a third file given with 
the difference between the two files to be able to perform the 
check only on modified components.
To execute the function it is necessary to import the cad files 
(follow the procedure for importing cad files) at the end of which 
the program requests to open the old file (Load Old File) and then 
the new file (Load New File).
Need the reference fiducial 
The data table is populated with the differences highlighted with 
the respective colors and the fiducial.
Perform the learning of the fiducial 
and perform component verification.

15.8)  Exporting the table of incorrect components
File -> Export Wrong Components: exports the list of components 
checked in WRONG column.
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15.9)Special Keys
When the cad file is imported into the data table, selecting a row
of the data table (the line turns blue) it is possible to make 
changes
Right mouse button -> Duplicate or CTRL + C duplicates the line
Right mouse button -> Erase or DEL delete the selected line
Right mouse button -> Assign Current Position
Update the quota of the component of the current row to the 
current dimension to view details of the component otherwise out 
of sight.
To use this function it is necessary to position yourself on the line 
of the component you want to modify, go to JOG 
and move the camera to desired point, select the line 
-> right button ->Duplicate.
The quota of the line will be updated to the desired one.
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16) File conversion from pick & place
16.1) File conversion from Mydata: save the assembly file as an HTML 

file using a standard browser (for example Chrome).  Open the file 
and select component rows with values and dimensions

In the example: 
1 C20 C12-410,0V50X7R

COND. 100nF 50V
1206 SMD X7R

P53 -49.632mm 66.666mm 0.000mm 90° 0
Illuminazione telecamera Linescan 
personalizzata per HYDRA

2 C21 C12-410,0V50X7R
COND. 100nF 50V
1206 SMD X7R

P53 -44.437mm 66.699mm 0.000mm 90° 0
Illuminazione telecamera Linescan 
personalizzata per HYDRA

3 C23 C12-322,0V50X7R
COND. 22nF 50V 
1206 SMD X7R

P11 -80.696mm 116.844mm 0.000mm 90° 0

4 C24 C12-410,0V50X7R
COND. 100nF 50V
1206 SMD X7R

P53 -18.449mm 99.108mm 0.000mm 90° 0 Illuminazione telecamera Linescan 

Edit the values with an editor (for example notepad ++) by removing the mm text 

after the dimensions and the degree symbol ( ° ). 

Save the file with the .txt extension and proceed with importing the file with
Value Separators -Tab-
and the following File Header sequence: J, N, J, V, J, X, Y, J, R, J, J

Result : 
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17) Electric block diagram

18) Appendix
Power supply:
Productor: EDACPOWER
Model: EA1018G-1E
AC input: 100 – 240V~, 50/60Hz, 1A max
DC output: 12Vdc, 2A
Environment temperature: 5°C - 40° C (41°F - 104° F)
Power supply: 24W
For indoor use only • CEC Compliance

• RoHS Compliance
• Plug USA, EU, SAA, UK Type
• Over Voltage Protective Installation
• Protection Type: Auto-Recovery
• MTBF: >30,000 hours
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19) Legal Guarantee

LEGAL PRODUCT WARRANTY
1) HEXEL srl guarantees manufacturing defects relating to the 
products supplied for a period of one (1) year from the invoice 
date. Therefore the total legal guarantee period and will be 1 year 
from the invoice date.

2) The warranty is valid for standard products, products made to 
the customer's specific request are excluded from the extension.

3) The Warranty is applicable only when:
3.1 the installation and / or assembly of the Product are carried out
in compliance with the instructions attached to the Product and by 
specialized technical personnel;
3.2 Product maintenance is performed by specialized technical 
personnel, without making changes or repairs to the Products 
without written authorization from HEXEL srl or not covered in the 
relative technical specifications;
3.3 the limit values of temperatures and voltages are not exceeded 
and the Product is not exposed to mechanical loads not conforming 
to its destination;
3.4 the reported defect affects the functionality of the product;
3.5 in case of alleged defect, the product conditions must be kept 
unchanged for the execution of the appropriate checks;
3.6 the defective product must also be made available to HEXEL srl 
for technical analysis and for all the time necessary for their 
execution;
3.7 the defect, duly specified and proven in its nature and extent, 
must be reported in writing to HEXEL srl no later than thirty (30) 
days from the date of receipt of the products (in case of apparent 
defects) or from the discovery of the defect ( in case of hidden 
defects);
3.8 the Customer presents the invoice proving the purchase and 
that he has regularly paid the Product according to the terms and 
conditions of sale.

4) This warranty does not include:
4.1 Damage to the product due to negligence, transport, 
unforeseen and / or unforeseeable events, such as unforeseeable 
circumstances and / or force majeure (including current pulses, 
lightning), which exclude the traceability of these defects to the 
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Product manufacturing process ( vandalism, unauthorized 
alterations and anomalous atmospheric phenomena);
4.2 all additional costs deriving from the repair of the defect: for 
example labor costs for assembly and disassembly, transport of 
defective and new / repaired products, disposal, reimbursement of 
expenses, transfers, elevators or scaffolding will be charged to the 
customer;
4.3 The components subject to wear which can be assimilated to 
consumables (such as light sources, mechanical parts ..) 4.4 this 
warranty does not apply if the appliance is not used for the purpose
for which it was made;
4.5 this does not guarantee the integrity of the paint when the 
product is used in a saline environment or in the presence of 
corrosive agents.

5) In the event that the defect is covered by this warranty, HEXEL 
srl will choose, at its discretion, between the repair of the defective 
product and / or its replacement with an identical or equivalent 
item, compatibly with the technical evolution of the products and 
their components.

6) The one (1) year warranty is also valid for products that use an 
LED light source

7) The liability of HEXEL Srl for a product defect will in any case be 
limited to the sum paid for that defective product.

8) This warranty applies to the domestic and foreign markets.

9) In the event of a technical dispute, the parties will submit the 
product in dispute to an expert appraisal by a third party - 
appointed by mutual agreement or, in the absence of agreement, 
by the President of the Court of Vicenza. The expert's assessment 
will be binding on both parties. The costs will be borne by the 
parties at a rate of 50% each.

10) For matters not covered by these conditions, Italian law 
applies. The court of Vicenza – Italy - is exclusively competent for 
any dispute.
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